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BITMAP VERSUS VECTOR GRAPHICS 

Vector graphics describe images using lines and curves, called vectors that also include color and position 

information. When you edit a vector graphic, you modify the properties of the lines and curves that describe its 

shape. You can move, resize, reshape, and change the color of a vector graphic without changing the quality of 

its appearance. You can overlap objects so that they are partly hidden and alter transparency. Vector graphics are 

resolution independent, meaning they can be displayed on output devices of varying resolutions without losing 

any quality. 

Bitmap graphics describe images using dots, called pixels, arranged in a grid. Your computer screen itself 

consists of a large grid of pixels. In a bitmap graphic, each dot is assigned a color, and when viewed at the 

correct resolution, the dots go together like tiles in a mosaic to form the image. When you edit a bitmap graphic, 

you modify pixels, rather than lines and curves. These bitmap graphics are resolution dependent, because the data 

describing the image is fixed to a grid of a particular size. Enlarging a bitmap graphic can make the image's edges 

ragged, as pixels are redistributed within the grid. Displaying a bitmap graphic on an output device with a lower 

resolution than the image itself also degrades the image's quality.
 

Creating Web Graphics Using Fireworks MX 

Fireworks is both a bitmap editor and a vector drawing program. By combining these drawing methods into the 

same application, Fireworks gives you a very powerful and versatile set of tools. Fireworks has two modes for 

editing images: Vector mode and Bitmap mode. Vector mode is for creating vector images and Bitmap mode is 

for editing bitmaps. Both modes share the same toolbox panel but tool options differ based on the type of image 

and editing mode within which you are working. For example, the eraser works to delete a part of an image in 

Bitmap mode but for Vector images to remove part of an image you would use the knife tool. The Rectangle tool 

in Vector mode creates a vector image that can be resized and edited; once this object is flattened and becomes a 

bitmap it can no longer be easily resized. However in Bitmap mode, tools are available to blur, sharpen, or 

smudge a bitmap image that are not available in Vector mode. The Fireworks environment is similar to 

Dreamweaver's in that it uses panels to display an object's properties. These panels also allow the user to make 

changes to an image object or entire image. Many of the panels can be combined or tabbed and are also grouped 

together by default. 
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Sample Fireworks Panels 

        
THE FIREWORKS ENVIRONMENT 

 
 

In the center of the screen is the document window. In the center of the document window is the canvas. This is 

where the Fireworks document and any graphics you create are displayed. 

• At the top of the screen is a menu bar and most commands are accessible from this area. 

• On the left side of the screen is the Tools panel. If the Tools panel isn't visible, choose Window »Tools. The 

Tools panel is where you'll find tools for selecting, creating, and editing a variety of graphics and objects. 

• At the bottom of the screen is the Property inspector. If the Property inspector isn't visible, choose Window 

» Properties. The Property inspector displays properties for a selected object or tool. Once an object is 

selected, you can change the properties of that object easily. If no objects or tools are selected, the Property 
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inspector displays properties of the canvas or document. The Property inspector displays either two or four 

rows of properties. If the Property inspector only displays two rows, you can click the expander arrow in the 

lower right corner to see all properties. 

Fireworks has a variety of tools you can use by 

choosing the icon in the toolbox. Some tools are only 

available for vector images while others are only for 

bitmaps. These tools are clustered by type in the 

toolbar (e.g. Bitmap and Vector). 

 
CREATING VECTOR IMAGES AND APPLYING EFFECTS 

Let’s explore the options in the toolbar for creating original buttons and banners to use on the web. 

First, select the shape tool in the Vector section of the toolbar and, using your mouse, draw a shape on the canvas. 

Notice that the object's properties are displayed in the properties inspector at the bottom of your screen. Use the 

options in the properties inspector to change the way that your object appears (e.g. fill and stroke, stroke is the 

outline or border around your object). 

• Change the fill color and add a texture experimenting with low and high texture values 

• Alter the options for the stroke or outline of the shape using a contrasting color and also explore the many 

options for how this stroke or outline appears 

• Add a live effect to the shape such as bevel, drop shadow, or glow 
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VECTOR AND BITMAP OPTIONS 

Vector Bitmap 

    Multiple shapes in the Shape tool option      Altering edges and textures in the Smudge tool 

    Knife tool to segment sections of a vector 

graphic 

     Explore rubber stamp, replace color 

 

When you are ready to export your image, delete all unused >>white>> space on your canvas by selecting 

Modify >> Canvas >> Trim Canvas. Saving your file creates a .png file that contains all your unflattened 

image objects that can be used for future web images (e.g. a button template for your website). To use the image 

on the web or optimally in a multimedia presentation you will want to export your image as a .jpg (photos) or 

.gif (graphic with less than 256 colors) File >> Export (Images only). 
 

USING THE ASSETS PANELS: STYLES AND SHAPES 

As you create your graphics for a site, you will want to keep the look of the images consistent on each page. 

Instead of having to remember the exact color or font for a button, you can use the Styles feature. Styles are 

saved in the Styles folder, located in the Settings folder of your Fireworks folder. After you create a style, it is 

available for future graphic files. Styles can be created and applied to objects or to text. Text styles appear as 

ABC in the panel. You use styles In Fireworks to apply effects to the currently selected object. Editing the style 

does not automatically update or change any of the-objects in your document that used the style. There are also 

preset styles that you may use in a pinch. 

STYLES 

To apply a style: 

1. Choose Window >> Styles to open the Styles panel  

2. Select an object on the page or draw a new one. The object can be text or an object. 

3. Click any one of the Object Style icons in the panel. The style is automatically applied to the object. 

4. To apply a different style, click a different icon in the panel. 

To create a new style: 
 

1. Create text or an object and apply effects, fill, or stroke options. 
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2. With the object selected (it will appear outlined in blue), click the New Style icon at the bottom of the Styles 

panel . The Edit Style dialog box appears. 

3. All style options except for text options are checked by default. For text objects, all options are checked by 

default. Deselect any of the options you don't want to use for this style. 

4. Name the style and click OK. A new style with an icon is saved and placed in the panel. 

SHAPES 

To use the shapes option: 

1. Choose Window >> Auto Shapes to open the Auto Shapes panel. 

2. Using your mouse, drag the shape you wish to use from the shape panel onto your workspace or canvas. 

3. Explore changing options in your Properties Inspector such as fill color and stroke. 

4. The yellow handles (small squares) allow for additional customization and reshaping of your shape. 
 

OPTIMIZING BITMAP IMAGES 

When working with bitmap images such as digital photos, you will need to optimize them (alter them so that 

they are in an optimal format) so that they are the appropriate dimension and file size for use on the web or in 

your multimedia presentation. The first step in optimizing images for the web is to reduce their actual size or 

dimension. The second step is to experiment with the format and image quality.  

To set image dimension: 

1. Open your image. 

2. Drop and drag from the View menu to Magnification and choose 100%. You will see the actual size of the 

image as it would appear on a computer screen. 

3. If it is too large, drop and drag from the Modify menu to Canvas to Image Size. Make certain the Constrain 

Proportions box is checked so your image will not be skewed. Note: You will need to experiment with 

varying numeric configurations to achieve your desired size. A good standard size is between 200 and 300 

pixels. 

Choosing the Image Format 

Exporting your image and picking the correct image format is crucial to the optimization process. The most 

popular file formats for Web graphics are GIF and JPEG. GIF images are generally used for line art and 

images with solid colors, GIF images can contain transparent areas and can be used for animation files. The 

disadvantage to GIF images is that they are restricted to 256 colors. JPEG is generally used for photographic 

images or images with gradients and more colors. JPEG files cannot be transparent or used in animations. The 

Optimize panel is where you pick the formatting options for exporting the file.  
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To use the Optimize panel: 

1. Open your graphic or image file. 

2. Choose Window » Optimize to access the Optimize panel. 

3. Choose your settings basing your decisions on the nature of your image (e.g. photo or banner). 

 
Exporting as Gif 

If you choose GIF as your export file format, you need to pick the color palette for the export. 

1. Choose Window » Optimize. 

2. Choose GIF from the Export file format drop down menu. 

3. Choose a color palette from the Index palette drop down menu. The options are explained below. 

Color Palette Options for Gif Images 
 

• Adaptive: Creates a custom palette containing the majority of colors in the image. 

• WebSnap Adaptive: Creates a bridge between the Web 216 palette and the Adaptive palette.Colors within 

a certain tolerance are snapped to the closest Web-safe color, 

• Web 216: A palette of the 216 colors that work on both Macintosh and Windows computers. This is 

sometimes referred to as a Web-safe or browser-safe palette because it generates the bestresults on different 

platforms and different browsers. 

• Exact: Contains the exact colors in the image when the image contains 256 colors or less. 

• System (Macintosh or Windows): - Contains 256 colors as defined by either the Macintosh or Windows 

system colors 

• Grayscale: A palette of 256 (or fewer) shades of gray. Using this palette converts your image to grayscale. 

• Black & White: A palette of only two colors: black and white. 

• Uniform: A mathematical palette based on RGB pixel values. 

• Custom: The user defines this palette. 

Exporting as Jpeg 

Use JPEG to export photographs or any artwork with gradients or millions of colors in the image. Unlike GIF 

images, JPEG images don't need a color palette. JPEG is a lossy compression scheme that means that it looks at 

your image and removes information as part of its compression algorithm. This causes a loss in quality; you set 



FWMXJobaid.doc © 2004 Faculty Support 
  Armstrong Atlantic State University 

the level of quality for the compression in the Optimize panel.  

To export as JPEG: 

1. Open your image file. 

2. Choose Window >> Optimize and use the Export File Format drop down menu to choose JPEG. 

3. Use the JPEG pop up slider to determine the level of quality. The lower the number, the smaller the file 

and the lower the quality. 

Previewing in the Workspace 

Fireworks enables you to preview your images within the document window before exporting them. You can 

determine the export settings for each object on the page as you create it and preview the results. You can also 

split the document window into two or four preview windows to view different settings. Fireworks also displays 

the file size and the approximate download times within each preview window. While in preview mode, you 

cannot make any changes to the image. To switch to preview mode, click the Preview button at the top of the 

document window. The 2-Up button divides the document into two preview windows; the 4-Up button divides 

the document into four preview windows. In 2-Up and 4-Up modes, the first window displays the original image 

and can be edited. The other windows are previews only. Click anywhere within a window to select it. A black 

border appears around the selected window. Any changes you make in the Optimize panel are reflected in the 

selected window.  

ALTERING BITMAPS: FEATHERED IMAGES 

The edge of a selection is controlled in the Properties Inspector panel. The default edge is a hard edge. 

Occasionally, you may wish to have a softer edge on an image for a different effect. You can use feathering to 

softly blur the edges of your image.  

To blur the edges of your image: 

1. Open the image for which you wish to blur the edges. 

2. Use the Ellipse Marquee tool to draw an ellipse around your image to frame it as you wish. 

3. Choose Select >> Feather and type in a value for the feather radius or use the feather option in the Properties 

Inspector. 

4. Choose Select >> Select Inverse to select the inverse of your feathered elliptical selection and press the 

delete key to remove the background. You should now see your image >>framed>> with soft or blurred edges. 

ADDING TEXT ALONG A PATH 

Text along a path is a popular graphic effect, and it is easy to add in Fireworks. The text flows along the curve of 

a path (this must be drawn with a vector tool) and remains completely editable after it is attached to the path. The 

path can be a circle, a rectangle, or any freeform shape you create using the vector tools.  
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To attach text to a path: 

1. Draw a curved path using a Vector Path tool (line, brush, pen). 

2. Use the Text tool and type some text. Change the font, color, and size as you wish. 

3. Select both the path and the text with the Pointer tool by shift clicking (holding down the shift key and clicking 

with your mouse). 

4. Choose Text >> Attach to Path. 

5. To change the text after it is attached to the path, select the text and choose Text >> Editor. 

6. To detach the text from the path, choose Text >> Detach from Path. 

ADJUSTING TEXT FLOW ON THE PATH 

Several options control how the text flows on the path. The alignment of the text controls where the text is placed 

on the path. For a curved path the placement on the path logically follows the alignment: left-aligned text starts at 

the beginning of the path: right-aligned text ends at the end of the path. If your path is a circle, the text flow is a 

bit more complex. A circle consists of four anchor points: top, bottom, left and right. The path of the circle flows 

clockwise, with the beginning point located at 9 o'clock. 
 

 

 

 

To change text offset and orientation on a path: 

1. Select the path with the Pointer tool. 

2. In the Properties Inspector type the offset value in the Path Offset field to shift text on the path the number of 

pixels you wish (you may need to experiment with this option). 

4. To alter the orientation of the text on the path, choose Text >> Orientation and pick Rotate Around Path, 

Vertical, Skew Vertical, or Skew Horizontal. 

• Rotate Around Path is the default. Each letter Is placed perpendicular to the path. 

• Vertical positions each letter vertical to the page. 

• Skew Vertical rotates the letters on the path, but skews them vertically. 

• Skew Horizontal slants the letters horizontally based on the curve of the path. 
 

  


