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BITMAP VERSUS VECTOR GRAPHICS 

Vector graphics describe images using lines and curves, called vectors that also include color and 

position information. When you edit a vector graphic, you modify the properties of the lines and 

curves that describe its shape. You can move, resize, reshape, and change the color of a vector 

graphic without changing the quality of its appearance. You can overlap objects so that they are 

partly hidden and alter transparency. Vector graphics are resolution independent, meaning they 

can be displayed on output devices of varying resolutions without losing any quality.  

 

Bitmap graphics describe images using dots, called pixels, arranged in a grid. Your computer 

screen itself consists of a large grid of pixels. In a bitmap graphic, each dot is assigned a color, 

and when viewed at the correct resolution, the dots go together like tiles in a mosaic to form the 

image. When you edit a bitmap graphic, you modify pixels, rather than lines and curves. These 

bitmap graphics are resolution dependent, because the data describing the image is fixed to a grid 

of a particular size. Enlarging a bitmap graphic can make the image's edges ragged, as pixels are 

redistributed within the grid. Displaying a bitmap graphic on an output device with a lower 

resolution than the image itself also degrades the image's quality.  

 

Creating Web Graphics Using Fireworks 4.0 

Fireworks is both a bitmap editor and a vector drawing program. By combining these drawing 

methods into the same application, Fireworks gives you a very powerful and versatile set of 

tools. Fireworks has two modes for editing images: Vector mode and Image Edit mode. Vector 

mode is for creating vector images and Image Edit mode is for editing bitmaps. Both modes 

share the same toolbox but tools change based on the type of image and editing mode within 

which you are working. For example, the eraser tool looks like an eraser in Image Edit mode and 

a knife in Vector mode. The Rectangle tool in Vector mode creates a rectangle that can be resized 

and edited yet in Image Edit mode the same tool creates a bitmap rectangle that cannot be 

changed or resized.  The Fireworks environment is similar to Dreamweaver's in that it uses 

floating palettes (or panels) to display an object's properties. These panels also allow the user to 

make changes to the object, graphic, or drawing. Many of the panels are tabbed, with two or 

more panels combined. 
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Sample Fireworks Panels 

 

THE FIREWORKS TOOLBOX 

Fireworks has a variety of tools you can use by choosing the icon in the toolbox . If a tool shows 

a small black triangle in the bottom right corner, you can drop and drag from this triangle to 

access other tool options. 

Pointer  

Select Behind 

Export Area 

Selects and moves objects on the screen.  

Selects an object behind the currently selected object. 

Exports a portion of a document. 

Subselection Selects and moves paths on the screen, selects an object within a 

group, displays points on a path, and selects points.  

 

Rectangle and Ellipse 

Marquee 

 

Selects a rectangular or elliptical portion of a bitmap image.  

 

Lasso 

Polygon Lasso 

Selects a freeform shape in a bitmap image 

Selects a polygon-shaped area of a bitmap image.  

 

Crop Discards portions of a document. 

Magic Wand Selects similar colors in a bitmap image 

Line, Pen , Rectangle, 

Ellipse, and Polygon 

Draws objects as editable paths. 
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Pencil Draws free form strokes. 

Brush 

Redraw Path 

Draws brush strokes as paths 

Redraws a segment of a selected path of draws brush strokes as 

paths. The brush, fill, and effect characteristics of the path are 

retained. 

Scale 

Skew 

Distort 

Resizes and rotates objects 

Slants and rotates objects and changes perspective. 

Distorts and rotates objects. 

 

Freeform 

 

Reshape 

 

Path Scrubber 

 

Pulls or pushes a selected path or part of a path to reshape it.  

Reshapes the parts of a selected path that lie within the Reshape 

Area cursor area.  

Alters a path's pressure and speed characteristics when using a 

stylus without changing the path's shape.. 

Eyedropper Picks up color from anywhere on the screen. The color is applied 

to the active color well. 

Paint Bucket Fills objects with solid color, gradients, or patterns and adjusts 

fills with Paint Bucket handles.  

Eraser or Knife Eraser: Deletes pixels or changes their color when in Image Edit 

mode.  

Knife: Cuts a selected path into separate paths when the knife 

cursor is dragged across the selected path when in Vector 

Editing mode. 

Rubber Stamp Clones a portion of a bitmap image. 

Hotspots Draws an image map hotspot on the image in the shape of a 

rectangle, circle, or polygon.  

Slicing Draws a rectangular or polygon slice on the image. 

Hand Tool Grabs the document for movement within the window. 

Zoom Tool Changes the magnification of the document. 
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FEATHERED IMAGES 

The edge of a selection is controlled in the Tool Options panel. The default edge is a hard edge. 

Occasionally, you may wish to have a softer edge on an image for a different effect. You can use 

feathering to softly blur the edges of your image. 

To blur the edges of your image: 

1. Open the image for which you wish to blur the edges. 

2. Use the Ellipse Marquee tool to draw an ellipse around your image to frame it as you wish. 

3. Choose Modify > Marquee > Feather and type in a value for the feather radius. 

4. Choose Modify > Marquee > Select Inverse to select the background and press the delete key 

to remove the background. You should now see your image "framed" with soft or blurred edges. 

 

OPTIMIZING IMAGES USING THE EXPORT WIZARD 

When working with images, you will want to change them so that they are the dimensions and 

file size you wish for your web page or multimedia. The first step in optimizing images for the 

web is to reduce their actual size or dimensions. 

To set image size: 

1. Open your image. 

2. Drop and drag from the View menu to Magnification and choose 100%. You will see the 

actual size of the image as it would appear on a computer screen. 

3. If it is too large, drop and drag from the Modify menu to Image Size. Make certain the 

Constrain Proportions box is checked so your image will not be skewed. Note: You will 

need to experiment with varying numeric configurations to achieve your desired size. 

4. To export your image (you won’ t want to choose save) select File >> Export. If it is a digital 

photo, the best file format to use is .jpg if a graphic with few colors  choose .gif 

 

After you complete your artwork, you need to export it. Whether you are using your images on 

the Web or for multimedia, Fireworks provides several methods for creating the best quality 

images with the smallest file size possible. Fireworks exports the following formats: GIF, JPEG, 

PNG, TIFF, PICT (Macintosh), and BMP. 
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The Export Wizard helps you through the process of exporting your files. Choose File > Export 

Wizard to begin the process. The wizard asks a series of questions and then suggests file types 

and optimization settings. You can also set a file size for the Export Wizard to use as a target for 

the optimization. At the end of the question dialog boxes, the Export Preview dialog box opens 

with the optimization suggestions. Note: If you select Target Export File Size in the Export 

Wizard, Fireworks attempts to optimize the file at that size by adjusting the quality of JPEG files, 

modifying the smoothing for JPEG files, changing the color depth for GIF files, changing 

dithering settings for GIF files, and turning optimization on or off. 

 

Choosing the Image Format 

Exporting your image and picking the correct image format is crucial to the optimization 

process. The most popular file formats for Web graphics are GIF and JPEG. GIF images are 

generally used for line art and images with solid colors, GIF images can contain transparent areas 

and can be used for animation files. The disadvantage to GIF images is that they are restricted to 

256 colors. JPEG is generally used for photographic images or images with gradients and more 

colors. JPEG files cannot be transparent or used in animations. 

The Optimize panel is where you pick the formatting options for exporting the file.  

To use the Optimize panel: 

1. Open your graphic or image file. 

2. Choose Window > Optimize to access the Optimize panel. 

3. Choose your settings basing your decisions on the nature of your image (e.g. photo or banner). 

 

Exporting as Gif 

If you choose GIF as your export file format, you need to pick the color palette for the export.  

1. Choose Window > Optimize. 
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2. Choose GIF from the Export file format pop-up menu. 

3. Choose a color palette from the Index palette pop-up menu. The options are explained below. 

4. Use the Transparency eyedroppers to add or remove colors from the transparent area of the 

image. Use transparency to drop out the background of an image so the image can be placed 

over a background image.  

Select Interlaced if you want that option. Interlacing causes images to partially load in the 

browser at a low resolution and then transition to full resolution as they continue to download. 

 

Color  Palette Options for  Gif Images 

• Adaptive: Creates a custom palette containing the majority of colors in the image. 

• WebSnap Adaptive: Creates a bridge between the Web 216 palette and the Adaptive palette. 

Colors within a certain tolerance are snapped to the closest Web-safe color, 

• Web 216: A palette of the 216 colors that work on both Macintosh and Windows computers. 

This is sometimes referred to as a Web-safe or browser-safe palette because it generates the best 

results on different platforms and different browsers. 

• Exact: Contains the exact colors in the image when the image contains 256 colors or less. 

• System (Macintosh or Windows): - Contains 256 colors as defined by either the Macintosh or 

Windows system colors 

• Grayscale: A palette of 256 (or fewer) shades of gray. Using this palette converts your image to 

grayscale. 

• Black & White: A palette of only two colors: black and white. 

• Uniform: A mathematical palette based on RGB pixel values. 

• Custom: The user defines this palette. 

 

Exporting as Jpeg 

Use JPEG to export photographs or any artwork with gradients or millions of colors in the 

image. Unlike GIF images, JPEG images don’ t need a color palette. JPEG is a lossy compression 

scheme that means that it looks at your image and removes information as part of its 

compression algorithm. This causes a loss in quality; you set the level of quality for the 

compression in the Optimize panel. 

To export as JPEG: 
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1. Open your image file. 

2. Choose Window > Optimize and use the Export File Format drop down menu to choose 

JPEG. 

3. Use the JPEG pop up slider to determine the level of quality. The lower the number the 

smaller the file and the lower the quality. 

 

Previewing in the Workspace 

Fireworks enables you to preview your images within the document window before exporting 

them. You can determine the export settings for each object on the page as you create it and 

preview the results. You can also split the document window into two or four preview windows 

to view different settings. Fireworks also displays the file size and the approximate download 

times within each preview window. While in Preview mode, you cannot make any changes to the 

image. To switch to Preview mode, click the Preview tab at the top of the document window. 

The 2-Up tab divides the document into two preview windows; the 4-Up tab divides the 

document into four preview windows. In 2-Up and 4-Up modes, the first window displays the 

original image and can be edited. The other windows are previews only. Click anywhere within a 

window to select it. A black border appears around the selected window. Any changes you make 

In the Optimize panel are reflected in the selected window. 

 

ADDING TEXT ALONG A PATH 

Text along a path is a popular graphic effect, and it is easy to add in Fireworks. The text flows 

along the curve of a path and remains completely editable after it is attached to the path. The 

path can be a circle, a rectangle, or any freeform shape you create. 

To attach text to a path: 

1. Draw a curved path using the Pencil tool. 

2. Use the Text tool and type some text. Change the font, color, and size. 

3. Select both the path and the text with the Pointer tool by shift clicking. 

4. Choose Text > Attach to Path. 

5. To change the text after it is attached to the path, double-click the text to access the Text 

Editor. 

6. To detach the text from the path, choose Text > Detach from Path. 
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ADJUSTING TEXT FLOW ON THE PATH 

Several options control how the text flows on the path. First, the alignment of the text controls 

where the text is placed on the path. For a curved path the placement on the path logically 

follows the alignment: left-aligned text starts at the beginning of the path: right-aligned text ends 

at the end of the path. If your path is a circle, the text flow is a bit more confusing. A circle 

consists of four anchor points; top, bottom, left and right. The path of the circle flows clockwise, 

with the beginning point located at 9 o'clock. Text is aligned on the circle based on the beginning 

anchor point. 

 

To change text offset and orientation on a path: 

1. Select the path with the Pointer tool. 

2. Choose Window > Object to open the Object Properties panel. 

3. Type the offset value in the Text Offset field to shift text on the path the number of pixels in 

the direction of the path. 

4. To alter the orientation of the text on the path, choose Text > Orientation and pick Rotate 

Around Path, Vertical, Skew Vertical, or Skew Horizontal. 

· Rotate Around Path is the default. Each letter Is placed perpendicular to the path. 

· Ver tical positions each letter vertical to the page. 

· Skew Vertical rotates the letters on the path, but skews them vertically. 

· Skew Hor izontal slants the letters horizontally based on the curve of the path. 

 

ADDING LIVE EFFECTS 

Live Effects are pixel-based effects that apply to path, image, and text objects. Applying a Live 

Effect does not permanently change the original object. If you make a change to the original 

object, the Live Effects change accordingly. For example, you can create a button with a bevel 

and drop shadow. You can change the color, the size, or the shape of the button, and the effects 

are reapplied to the new button. Effect and the object upon which it is applied are both editiable. 
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The Live Effects are Glow, Emboss, Drop Shadow, Outer  Bevel, and Inner  Bevel. One or 

more effects can be added to an object. The effects can also be saved for use on other objects.  

To apply an effect to an object: 

1. Choose Window > Effect if the Effect panel is not already open. 

2. Select the object to which you want to apply the effect. 

3. Choose an effect from the Effect list. For example, choose Drop Shadow from the Shadow and 

Glow option and a pop-up window will appear. 

3. Change the settings to get the desired shadow effect. 

4. Click outside the Drop Shadow settings window to close it. 

To edit an effect: 

1. Select the object. 

2. Choose Window > Effect if the Effect panel is not already open. 

3. Click the Info icon next to the effect you want to change. 

4. Adjust the settings in the pop-up window or dialog box that appears. 

5. Click outside the pop-up window to close it or click OK to close the dialog box. 

 

When multiple effects are applied to an object, the order of the effects in the Effect list can 

change the look of the image. Effects that change the interior of an object (such as Inner Bevel) 

should appear before effects that control the outer edge (such as Outer Bevel). 

To reorder effects: 

1. Select the object. 

2. Choose Window > Effect if the panel is not already open. 

3. Select the effect name from the list and then drag either up or down in the list. 

This procedure works just like the procedure for changing the order of a layer. 

To save effects: 

1. Select the object with the effects you want to save. 

2. Use the right arrow at the top of the Effect panel to access the Options pop-up menu. 

3. Choose Save Effect As. 

4. Type a name in the dialog box and then click Save. 

The name now appears in the Effect list. 

To apply a saved effect to another object: 
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1. Select the object. 

2. Choose the effect from the Effect list.  

 

CREATING AND USING STYLES 

As you create your graphics for a site, you will want to keep the look of the images consistent on 

each page. Instead of having to remember the exact color or font for a button, you can use the 

Styles feature. Styles are saved in the Styles folder, located in the Settings folder of your 

Fireworks folder. After you create a style, it is available for all documents. Using Styles is the 

same as copying an object and then selecting another object and choosing Edit > Paste 

Attributes. Styles are just easier, and the information is saved for you to use over and over. Styles 

can be created and applied to objects or text. Text styles appear as ABC in the panel. You use 

styles In Fireworks to apply effects to the currently selected object. Editing the style does not 

automatically update or change any of the-objects in your document that used the style. 

Styles can also be exported and shared among other members of your team to create a corporate 

style guide. This ensures consistency among all the Web pages for the graphics you create. 

To apply a style: 

1. Choose Window > Styles to open the Styles panel  

2. Select an object on the page or draw a new one. The object can be text, a complex path, or a 

simple geometric figure created or imported. 

3. Click any one of the Object Style icons in the panel. The style is automatically applied to the 

object. 

4. To apply a different style, click a different icon in the panel. 

Note: If you do not see any style icons in the panel, you need to import the default styles. Skip to 

the section "To import a style" to see the step-by-step process. The default styles are in the Styles 

folder, located in the Settings folder of your Fireworks application. 

To create a style: 

1. Use existing text or an existing object. Apply any effects, fills, or strokes. 

2. With the object selected, click the right-pointing arrow in the Styles panel to access the Styles 

Options pop-up menu. Choose New Style. The Edit Style dialog box appears. 

3. All style options except for text options are checked by default. For text objects, all options are 

checked. Deselect any of the options you don't want to use for this style. 
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4. Name the style and click OK. A new style with an icon is saved and placed in the panel. 

 

To edit a style: 

1. Deselect any objects on the page. 

2. On the Styles panel, select the style icon for the style you want to edit. Notice the thin black 

line around the Icon, indicating that it is selected. 

3. Select Edit Style from the Styles Options pop-up menu, or double-click the icon.  The Edit 

Style dialog box appears. 

4. Make any changes; the preview box shows the effect of your changes. 

5. Click OK. The style is now edited. 

Note: After a style has been created, you edit its appearance on an object by checking or 

unchecking any of the options. This does not change the original setting; you toggle an option off 

and on only for the selected object. 

To delete a style: 

1. Select a style or styles in the panel. To select multiple styles, Shift-click the Icons in the panel. 

Use Command-click (Macintosh) or Ctrl-click (Windows) to select noncontiguous icons in the 

panel. 

2. Choose Delete Styles from the Styles Options pop-up menu. 

To export a style: 

1. Select a style or styles in the panel. To select multiple styles, Shift-click the icons in the panel. 

Use Command-click (Macintosh) or Ctrl-click (Windows) to select noncontiguous icons In the 

panel.  Note: Only your selected styles will be exported. If no styles are selected, the option is 

dimmed. 

2. Choose Export Styles from the Styles Options pop-up menu.  The Save As dialog box appears. 

3. Type a name for the styles. The extension .sti is applied to the file name for you. 

4. Click Save. 

To import a style: 

1. Choose Import Styles from the Styles Options pop-up menu. The Open dialog box appears. 

2. Find the style file you want to import. You might need to browse to find the Styles folder in 

the Settings folder of your Fireworks application. 
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3. Click the Open button. The styles are placed in the list directly after the currently selected 

style, or at the end, if no style is selected. 

 

SAVING THE HISTORY STEPS AS A COMMAND 

If you save the History steps as a command, you can then replay these actions at any time or in 

any Fireworks document. The command you save appears In the Commands menus and remains 

there until you delete it. When you access the menu item, the steps are replayed. This is a great 

way to recreate a button you want to use in multiple documents, You create it once, save the 

steps to create the button as a command, and then replay the command in each document where 

you need the button. 

To save history steps as a command: 

1. Create an image using Fireworks options (e.g. draw a rectangle the size of a button on the 

canvas; fill the button with a gradient; use the Text tool and type Home; and change the font, 

size, and color of the text to fit inside the rectangle). 

3. Open the History panel and select the steps for creating your image. 

4. Click the right arrow to display the Options pop-out list. 

5. Select Save as Command from the list. 

6. In the Save as Command dialog box that appears, type a descriptive name for the steps. 

7. To execute the command, in a new document, select the command name you saved from the 

Commands menu. A new button is created on the page and is placed in the same location as the 

original button. 

TO INSERT A ROLLOVER: 

1. In the document window, place your cursor at the point at which you wish to insert your 

rollover. 

2. Insert the rollover by using one of these methods: 

·  From the Objects Palette, click the Insert Rollover icon . 

·  Choose Insert > Interactive Images >Rollover Image. 

3. The Inser t Rollover  Image dialog box appears. 
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4. In the Image Name field, type a name for the rollover image. 

5. In the Or iginal Image field, click Browse and select the image you wish displayed when your 

page loads.  

6. In the Rollover  Image field, click Browse and select the image you wish displayed when the 

user’s mouse passes over the original image. NOTE: You will need to create these two 

identically sized images in an image editor such as PhotoShop or Fireworks. 

7. It is recommended that you choose the option Preload Rollover  Image so that the images will 

preload in the browser©s cache, this means that they will load faster when the rollover is used. 

8. In the When Clicked Go to URL field, click Browse and select the file, or type the web 

address (e.g. http://www.website.com). 

Note: If you don©t set a link for the image, Dreamweaver inserts a null link (#) in the HTML 

source code to which the rollover behavior is attached. If you remove the null link, the rollover 

image will no longer work. So either leave the # in the Link field or enter a page or site to which 

to link. 

9. Click OK to close the Insert Rollover Image dialog box.  

10. Test your rollover by choosing File > Preview in Browser or press F12. In the browser, move 

the pointer over the original image. The initial image should switch to the rollover image. 

 


