
advancedDW4.doc ã  2002 Faculty Support 
 Armstrong Atlantic State University 

Taking the Next Step: Advanced Dreamweaver 
 

Part of Dreamweaver's strength as a web-editing tool is its flexibility.  As you develop as a web designer and 

improve and increase your skills and conceptual understanding, you will find that Dreamweaver grows with 

you.  You can use it to perform basic, straightforward tasks such as adding text, graphics, and links to your web 

pages and can use the software to incorporate HTML Styles, create online forms, and carry out other more 

complex tasks. You already have a good working understanding of Dreamweaver as a web editor, so you are 

now ready to extend and enrich your knowledge of this powerful web development software. 

 

A brief review of the components of the Dreamweaver environment: 

 

In addition to the basic components (properties inspector, object palette, and toolbar) in the Dreamweaver 

workspace, there are also the tag selector and launcher bar both of which will be used in our discussion of 

advanced Dreamweaver. 

 

Html and CSS Styles in Dreamweaver: 

An HTML style applies formatting to text in a predetermined or defined manner and can combine tag properties 

such as b, i, font, and center. The HTML 4.0 specification released by the World Wide Web Consortium (W3C) 
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in early 1998 discourages the use of HTML formatting tags in favor of CSS style sheets. HTML formatting tags 

offer less control and sophistication over appearance than CSS style sheets and take longer to load however they 

are supported by a much wider range of browsers than CSS style sheets. CSS style sheets are only supported in 

4.x browsers and later so if you suspect that some of your users may use older browsers, use of CSS is probably 

not your best option. CSS is very helpful when you have a large number of pages for which you wish to have a 

consistent look and feel (color, font, etc.) and you anticipate that you may make frequent changes to these page 

elements. CSS can greatly assist in making your workflow more efficient but keep in mind that all options are 

not supported in all browsers. 

Using HTML Styles 
 
Use HTML Styles to save text and paragraph formatting combinations that you want to use consistently 

throughout your documents. Once you have created an HTML style, you can reapply that formatting to any text 

in any document using the HTML Styles panel. 

 

 

Unlike CSS styles, HTML style formatting only affects text to which you directly apply it. If you change the 

formatting of an HTML style you have created, text that was originally formatted with the older version of that 

style is not updated. In other words, you must apply it to your text each time the style changes.  

To display the HTML Styles panel, do one of the following: 1/Choose Window > HTML Styles, or 2/ Click the 

HTML Styles icon in the Launcher Bar. 

To view an existing HTML style:  

1. In the HTML Styles panel, select a style. There are both paragraph styles and selection styles. Note: Clear 

Paragraph Style and Clear Selection Style are used to remove styles from a selection or paragraph. 

2. While in the HTML Styles panel, right-click (Windows) or Control-click (Macintosh) a style and choose Edit 

from the menu; double-click the HTML style and choose Edit from the menu; or highlight the style and drop 
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and drag from the fly out menu to the right of the panel. Note: You may wish to deselect the auto apply 

checkbox so that the style is not automatically applied to text in your document. 

3. In the Define HTML Style dialog box, specify the settings for the style. The Apply To options determine 

whether the style applies to the selected text (Selection) or the current text block (Paragraph). The When 

Applying options determine whether the settings for the style are added to the original text formatting (Add to 

Existing Style), or removed from the existing formatting and replaced with the new settings (Clear Existing 

Style). 

To apply an existing HTML style:  

1. Highlight the text you wish to format with an HTML style. 

2. In the HTML Styles panel, select a style. If the Auto Apply checkbox at the bottom of the panel is selected, 

click the style once. If the Auto Apply checkbox is not selected, click the style then click Apply. 

To clear text formatting in your document:  

1. Select the formatted text. 

2. In the HTML Styles panel, click Clear Paragraph Style or Clear Selection Style. Clear Paragraph Style 

removes any formatting from the current text block in the document. Clear Selection Style removes any 

formatting from the highlighted text. 

To remove a style from the HTML Styles panel:  

1. In the HTML Styles panel, deselect the checkbox to turn off the Auto Apply option. 

2. Select an HTML style. 

3. Click the Delete Style (trash can) icon in the lower right corner of the panel. 

To create a new HTML style based on existing text:  

1. In your document, select or create text that has the formatting you want to use as the basis of your new 

HTML style. You can use the Property inspector to set your preferred formatting. 

2. In the HTML Styles panel, click the New Style icon (plus sign) in the lower right corner. 

3. In the Define HTML Style dialog box, name the style and select your preferences for formatting. Select 

whether to apply the HTML style to selected text or the entire paragraph. Note: A paragraph style applies to the 

entire text block in which the insertion point is located, regardless of what text is actually selected. Keep in mind 

the hierarchy for applying styles is that HTML Styles take precedence over CSS styles, which take precedence 

over external CSS styles. Note: The formatting options in the HTML Styles panel match those in the Property 

Inspector. 

4 Click OK. 

To create a new HTML style from scratch:  

1. In the HTML Styles panel, click the New Style icon; you can also choose Text >HTML Styles > New Style. 

The Define HTML Style dialog box appears. 
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2. Complete steps 3 and 4 in the instructions for creating a new style based on existing text. Click Clear to reset 

the dialog box to the default options. 

3. Click OK. 

To edit an existing HTML style:  

1. Make sure no text is selected in the document window. 

2. In the HTML Styles panel, make sure the Auto Apply checkbox is deselected. If the Auto Apply option is 

turned on, the HTML style will be applied when you select it in the HTML Styles panel. 

3. In the HTML Styles panel, right-click (Windows) or Control-click (Macintosh) the style, then choose Edit 

from the context menu. The Define HTML Style dialog box appears. To reset it to the default options, click 

Clear. When you edit an HTML style, Dreamweaver does not automatically update text that was previously 

formatted using the HTML style. 

Using CSS style sheets 
 
A style is a group of formatting attributes that control the appearance of a range of text in a single document. A 

CSS (Cascading Style Sheets) style can be used to control many documents at once and includes all of the styles 

for a document. The advantage of using a CSS style sheet over an HTML style is that in addition to being linked 

to multiple documents, when a CSS style is updated or changed, the formatting of all the documents that use that 

style sheet are automatically updated as well. CSS style sheets work in 4.0 and later  browsers. Internet 

Explorer 3.0 recognizes some CSS style sheets, but most earlier browsers ignore them. Three types of CSS style 

sheets are available in Dreamweaver: custom styles, selector styles, and tag styles. Manual HTML formatting 

and HTML styles overrides formatting applied with CSS. To use CSS styles to control the formatting of a 

paragraph, you must remove all manual HTML formatting or HTML styles. Note: For more information on CSS 

display the O'Reilly CSS reference guide included with Dreamweaver 4.0 by clicking the Reference button 

found on the toolbar; choose O'Reilly CSS Reference from the pop-up menu.  

NOTE: The CSS styles section of the Dreamweaver help files contain detailed information about how to create 

styles, link to external styles, and other tasks related to CSS. To link to this information drop and drag from the 

Help Menu to the Using Dreamweaver item. 

 

Creating Forms in Dreamweaver 

Forms allow you to gather information from users on your site. For example, you can ask for a user's name and 

e-mail address, or have visitors take a survey, sign a guest book, or provide feedback on your site. Forms have 

two parts: HTML source code describing the form (for example, the fields, labels, and buttons a user sees on the 

page), and a script or application to process the information submitted (such as a CGI script). You can't collect 

form data without using a processing script. You can create the web form, but the CGI script is a server side 

process. Once you have created the form, contact Faculty Support for assistance with having the script generated 
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to process your form. You can use Dreamweaver to create a variety of form objects such as text fields, radio 

buttons, checkboxes, pop-up menus, or clickable images (such as a Submit button). You can also use 

Dreamweaver's validate form behavior to verify the information a visitor provides; for example, you can check 

that an e-mail address contains an @ symbol, or that a required field contains an entry. In Dreamweaver, form 

input types (e.g. fields and buttons) are called form objects. You can insert form objects by using the Forms 

category in the Objects panel, or by choosing Insert > Form, and Insert > Form Objects. 

The Forms category provides the following icons:  

·  Inser t Form inserts a form in the document. Any additional form objects, such as text fields, buttons, 

and so on must be inserted within the form boundary for the data to be processed correctly by all 

browsers.   

·  Inser t Text Field inserts a text field in a form. Text fields accept any type of text, alphabetic, or numeric 

entries. The entered text can be displayed as a single line, as multiple lines, or as bullets or asterisks (for 

password protection).  

·  Inser t Button inserts a text button in a form. Buttons perform tasks when clicked, such as submitting or 

resetting forms. You can add a custom name or label for a button, or use one of the predefined labels—

Submit or Reset.  

·  Inser t Checkbox inserts a checkbox in a form. Checkboxes allow multiple responses in a single group 

of options, a user can select as many options as apply.  

·  Inser t Radio Button inserts a radio button in a form. Radio buttons represent exclusive choices. 

Selecting a button within a group deselects all others in the group, for example a user can select Yes or 

No.  

·  Inser t L ist/menus allows you to create user choices in a list. The List option displays the option values 

in a scrolling list and allows users to select multiple options in the list. The Menu option displays the 

option values in a drop-down list and allows users to select only a single choice.  

·  Inser t Jump Menu inserts a navigational list or pop-up menu. Jump menus let you insert a menu in 

which each option links to a document or URL. (NOTE: You can use Jump menus as navigational aids 

as well as form choices. See below for directions.) 

Naming your form objects is essential for the successful generation of the cgi script and to be certain that your 

data output is formatted correctly. Important Note: Radio buttons for a single question should all have the same 

label or name (e.g rb1) but unique checked values. All other form elements (text fields, check boxes) should 

have separate and unique labels. Also for these other elements, checked values and labels should be the same. 

Keeping the form labels short helps make creating the cgi script more efficient, so try to make the form object 

names logical but brief. 
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To add a form to a document:  

In the document, place the insertion point where you want the form to appear, then do one of the following: In 

the Forms category in the Objects panel, select the Insert Form icon or Choose Insert > Form. When a form is 

created a dotted red outline appears in the document window.  

To add a form object to a document:  

Place the insertion point inside the form (delineated by the red line) where you want the form object to appear, 

then do one of the following: 1/ in the Objects panel's Forms category select the Insert Form Object (your 

choice) icon or 2/ Choose Insert > Form Object. When a form object is added, you will need to give it a unique, 

meaningful and brief name or label in the properties inspector and set the specific properties you desire for that 

form object. You will also need to give it a unique checked value. 

 

Behaviors 

Behaviors help users interact with your Web page and cause certain actions to be performed. A behavior is a 

combination of an event with an action triggered by that event. Adding a behavior to your page is a two step 

process. Behaviors are executed using javascript, a scripting language that is compatible with html code. In the 

Behaviors panel, you specifying an action and determine the event (e.g. mouse over or mouse click) that 

triggers that action. Different events are defined for different page elements; for example, in most browsers 

onMouseOver and onClick are events associated with links, whereas onLoad is an event associated with images 

and with the page itself.  An action consists of prewritten JavaScript code that performs a specific task, such as 

opening a new popup window when your page loads, creating a rollover or swap image, playing a sound, or 

checking for plugins. After you attach a behavior to a page element (e.g. link or image), whenever the event 

occurs, the browser calls the action (the JavaScript code) that you've associated with that event. For example, if 

you attach the Popup Message action to a link and specify that it will be triggered by the onMouseOver event, 

then whenever someone points to that link with the mouse pointer in the browser, your message pops up in a 

dialog box.    

Open Browser Window Action options 
 
Use the Open Browser Window action to open a web page in a new window. You can specify the properties of 

the new window, including its size, attributes (whether it is resizable, has a menu bar, and so on), and name. 

This is what occurs when you see a small popup window appear when you browse a particular web page. 

To use the Open Browser Window action to Create a Popup:  

1. Position your cursor anywhere on the page and open the Behaviors panel. 

2. Click the plus (+) button and choose Open Browser Window from the Actions menu. 

3. Click Browse to select a file, or enter the URL you want to display. 

4. Set any of the following options:  
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·  Window Width specifies the width of the window in pixels.   

·  Window Height specifies the height of the window in pixels.   

·  Navigation Toolbar  is the row of browser buttons that includes Back, Forward, Home, and Reload.   

·  Location Toolbar  is the row of browser options that includes the location field.   

·  Status Bar is the area at the bottom of the browser window in which messages appear.   

·  Menu Bar is the area of the browser window (Windows) or the desktop  (Macintosh) where menus such 

as File, Edit, View, Go, and Help appear. If you do not set this option, the user can only close or 

minimize the window.   

·  Scrollbars as Needed specifies that scroll bars should appear if the content extends beyond the visible 

area. If you do not explicitly set this option, scroll bars do not appear.  

·  Resize Handles specifies that the user should be able to resize the window, either by dragging the lower 

right corner of the window or by clicking the maximize button (Windows) or size box (Macintosh) in the 

upper right corner. If the Resize Handles option is also turned off, visitors have no easy way of seeing 

content that extends beyond the original size of  the window.  

·  Window Name is the name of the new window. You should name the new window a name that does not 

contain spaces or special characters. 

5. Click OK. 

To cause your linked web page to open in a new browser window:  

1. Highlight the text you wish to serve as your link. 

2. In the link field of the property inspector type a # (pound sign). 

3. Open the Behaviors panel and highlight the linked text you just set with the #. 

2. Click the plus (+) button and choose Open Browser Window from the Actions menu. 

3. Click Browse to select a file, or enter the URL you want to display. 

4. Set any of the options for your popup listed above. 

5. Click OK. 

6. In the Behaviors panel make certain that the event displays OnClick. 

Validating a Form 
 
The Validate Form action checks the contents of specified text fields within a form to ensure that the user has 

entered the correct type of data. Attach this action to individual text fields with the onSubmit event to evaluate 

several text fields at once when the user clicks the Submit button. Attaching this action to a form prevents the 

form from being submitted to the server if any of the specified fields contains invalid data or blank fields.  

1. Create your form with text fields you wish to use to collect user data (e.g. name, address, etc.) 

2. To validate multiple fields when the user submits the form, select the Submit button in your form. 
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3. Open the Behaviors panel and choose Validate Form from the Actions pop-up menu. 

4. In the Validate Form window choose specific text fields (this is why it is important to give your form objects 

meaningful names) and select the options you wish for each. 

 

·  Select the checkbox next to Required for required fields. 

·  Use Anything if the field is required but need not contain any particular kind of data.  

·  Use E-mail address to check that the field contains an @ symbol. 

·  Use Number to check that the field contains only numerals. 

·  Use Number From to check that the field contains a number in a specific range. 

5. Click OK. 

Playing a Sound 
 
Use the Play Sound action to play a sound that you have recorded or downloaded and placed in an appropriate 

location in your web site (e.g. a sounds folder). You might want to play a sound effect whenever the mouse 

pointer rolls over an image or clicks a link, or you might want to play a music clip when the page loads. Note: 

certain browsers may require some kind of additional audio support (such as an audio plugin) to play sounds.  

To use the Play Sound action to attach to an object on your page:  

1. Select an object (link or image) and open the Behaviors panel. 

2. Click the plus (+) button and choose Play Sound from the Actions pop-up menu. 

3. Click Browse to locate and select a sound file. 

4. Click OK. 

NOTE: You can edit the event by using the drop down menu next to the event listing and then choosing a 

different selection (e.g. onClick or onMouseOver) 

To use the Play Sound action to play a sound when your page loads:  

1. Click anywhere in the white space on your page and open the Behaviors panel. 

2. Click the plus (+) button and choose Play Sound from the Actions pop-up menu. 

3. Click Browse to locate and select a sound file. 

4. Click OK.  
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Redirecting a web page to another  page 

Use the Refresh element to specify that the browser should automatically refresh your page—by reloading the 

current page or going to a different one—after a certain amount of time. This element is often used to redirect 

users from one URL to another, often after displaying a text message that the page has changed addresses (e.g. 

This page has moved. Please reset your bookmarks to http://www.mycoolpage.com)  

·  Delay is the time in seconds to wait before the browser refreshes or redirects the page. To make the 

browser reload the page immediately after it finishes loading, enter 0 in this text box.  

·  Action specifies whether the browser should go to a different URL or refresh the current page, after the 

specified delay. To make a different URL open (rather than refreshing the current page), click the 

Browse button, then browse to and select the page to load or type in the URL. 

To create a redirect: 

1. Choose Head from the pop-up menu at the top of the Objects panel and click the refresh icon. 

 

2. Enter options for the element in the dialog box that appears, or in the Property inspector. 

3. Press OK. 

Creating a Jump Menu 
 
A jump menu offers your users a listing of links to URLs or files. You can create links to web sites (URLs), 

links to documents within your Web site, or links to any file type that can be opened in or downloaded from a 

browser. This approach is often used with web sites that offer Quick Links from a homepage (e. g. AASU’s 

homepage). 

To create a jump menu:  

1. Choose Insert > Form Object > Jump Menu. The Insert Jump Menu dialog box appears. 

 

2. In the Text field of the Insert Jump Menu dialog box, type the text you want to appear in the menu list. 
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3. In the When Selected, Go To URL field, select the file to open or URL to go to by choosing Browse, then 

select the file to open or by typing in the web address or URL. 

4. To add a new list item, click the plus (+) button at the top of the Insert Jump Menu dialog box and repeat 

steps 2 and 3. 

5. You can also rearrange the order of your items by selecting an item and using the up or down inverted 

triangle keys at the top of the Insert Jump Menu dialog box. 

6. When you have added all of your list items, click OK. 

NOTE: To edit your jump menu, you can either make changes through the Properties Inspector or in the 

Behaviors panel by double clicking on the Action (Jump Menu). 


