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What is HTML?  

HTML is an acronym for HyperText Markup Language, the programming language used to create pages for 

publishing on the World Wide Web. HTML enables you, the designer, to create hypertext links to other HTML 

files and also allows you to include static and interactive graphics, video, and sound files in your document; this 

is done by inserting special strings of characters, called HTML tags, into your document. These tags control the 

structure and behavior of the text or the bits of information to be displayed.  Most HTML tags have an opening 

and closing tag; the closing tag is indicated by a forward slash. The HTML syntax comprising the tag is 

surrounded by a left and right angle bracket. 

 

<font size="+3"> This is text in a larger font size.</font> 

 

Creating Web Pages Using Dreamweaver 4.0 

Dreamweaver is a very powerful HTML editor that can help you create web pages using simple and 

straightforward processes as well as more complex and sophisticated ones. Many web developers have referred 

to Dreamweaver as the industry standard for HTML editors. We, in higher education, find it quite useful as 

well! 

LET’S GET STARTED 

1. Start Dreamweaver. A window will appear that looks like this: 

 

The Dreamweaver environment includes a collection of floating palettes; the two most basic and important are 

the Property Inspector  and the Object Palette. The floating palettes (Object Palette, Launcher and Property 

Inspector) may appear in different positions to those shown above. It is possible that occasionally they will be 
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‘ floating’  outside the Dreamweaver document window. If you don’ t see one or all of them, drop and drag from 

the Window menu at the top of the screen and select the palette you wish to appear. You can move each palette 

by “grabbing”  it with your mouse and placing where you wish. 

Object Palette  

 

The Object Palette contains buttons for 

inserting objects such as tables, layers, and 

images.  To show or hide the Object 

palette, choose Window > Objects.  To 

insert an object, click the corresponding 

object palette button. The Object Palette 

contains six panels by default: Characters, 

Common, Forms, Frames, Head, and 

Invisibles. Use the drop down menu at the 

top of the palette (the default is Common) 

to switch between panels. 

 

Property Inspector 

 

The Property Inspector displays properties for selected objects. Text 

properties include font type, font size, link/URL, text color, etc. Other properties 

provided in the properties inspector are specific to the element selected such as 

image (size, alt tag, etc.) and table (number of rows and columns, border, etc.) 
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The Object Palette for Dreamweaver  

The Object palette contains the following panels:  

·  The Common panel contains the most commonly used objects, such as Image, Table, and Layer. 

·  The Characters panel contains special characters such as the copyright symbol, curved quotation 

marks, and trademark symbols. (Note that these symbols may not display correctly on browsers other 

than Netscape Navigator 3 and 4 and Internet Explorer 3 and 4.) 

·  The Forms panel contains buttons for creating forms and form elements. 

·  The Frames panel contains common frameset structures. 

·  The Head panel contains buttons for adding various HEAD elements, such as META, KEYWORDS, 

and BASE tags.  

·  The Invisibles panel contains buttons for creating objects that are not visible in the Document window, 

such as named anchors. Choose View > Invisible Elements to display icons that mark the locations of 

these objects. Click invisible-element icons in the Document window to select the objects and change 

their properties. See About invisible elements. 

The Specific Icons on the Objects Menu 
Common 
The Common panel in the Object palette contains the most commonly used objects:  
 

 Image Places an image at the insertion point. A dialog box appears so that you can specify an image file and some properties of 
the image. 

 Rollover  Prompts you to specify two image files that are used to define a rollover. A rollover is an image that changes when the 
pointer moves across it.      

 Table Places a table at the insertion point and allows for customization of that table (cells, columns, rows).  

 HR Places a horizontal rule at the insertion point.  

 Navigation Bar  Inserts a set of images to be used for navigating through a site and helps determine links to other pages or web 
sites.  

 Layer  Creates a layer. Click the Layer button, then move the pointer to the Document window and drag to define the size and 
location of a layer. Layers can be used to place information on top of other information or hide information and attach them to button 
behaviors. 

 L ine Break Places a line break (<br>) at the insertion point. You can also press Shift+Enter (Windows) insert a line break. This 
appears as a single space as opposed to a double space that you get when you press Enter. 

 E-Mail L ink Places an e-mail link at the insertion point. You type in the hyperlinked text and your email address.      

 Date Places the current date at the insertion point. A dialog box appears in which you can specify a format for the date and 
indicate whether Dreamweaver should update the date automatically every time you save the file.  

 Flash Places a Flash movie at the insertion point using the OBJECT and EMBED tags. See Flash movie properties in the 
Dreamweaver help menu for more information. 
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Characters 
The Characters panel in the Object palette contains some special characters:  
 

 Copyr ight Places a copyright symbol at the insertion point.  

 Registered Places a registered-trademark symbol at the insertion point.  

 Trademark Places a trademark symbol at the insertion point.  
 

Forms 
The Forms panel in the Object palette contains buttons for creating forms and form elements. See Forms overview in the 
Dreamweaver help menu for more information. 
 
Place the insertion point within a form boundary before inserting a form element; form elements outside of forms do not appear in a 
browser. If you attempt to insert a form element outside of a form, a dialog box asks whether to add a form tag around the form 
element; click Yes to create a new form containing the element, or No to insert the element without a form.  
 

 Form Places a form at the insertion point. Forms are simply containers for form elements; the form boundaries are not visible in 
the Document window unless View > Invisible Elements is on  

 Text Field Places a text field at the insertion point. Set the name, size, and initial value in the Property inspector.  

 Button Places a button with a default NAME and VALUE of "Submit" at the insertion point.  

 Checkbox Places a checkbox at the insertion point. Set the name, value when checked, and initial state in the Property inspector.  

 Radio Places a radio button at the insertion point. Set the name, value when checked, and initial state in the Property inspector  

 L ist Menu Places a list or pop-up menu at the insertion point. Set the name, type, and list values in the Property inspector.  
      

Head 
The Head panel contains objects for adding elements to the HEAD section of your documents. You will probably not use these objects 
very often as they add information to the source code of your document and do not change the functionality. 
 

Invisibles 
The Invisibles panel contains buttons for creating objects that are not visible in the Document window.  
 
Choose View > Invisible Elements to display icons that mark the locations of these objects. Click the icons to select the objects and 
change their properties.  
 

 Anchor  Places a named anchor (<a name="">) at the insertion point. A dialog box appears; enter a name for the anchor. For 
more information about creating and using Anchors refer to your Dreamweaver help menu and the “Linking to a named anchor”  
section.  

 NBSP Places a nonbreaking space (&nbsp;) at the insertion point. (A nonbreaking space prevents a line break from occurring 
between two words.)  It also inserts extra spaces (much like pressing the space bar in word processsing. 
 

The Menu Bar  

Dreamweaver has nine main menus on the menu bar of the Document window. The menus follow the standard 

Windows format of having File and Edit on the left and Window and Help on the right. The menus are 

described in detail below: 
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File 

The File menu deals with all the file-handling aspects of Dreamweaver such as opening, saving and creating 

new files or sites. This menu also contains data handling commands such as the importing, exporting, and 

converting of documents. Link checking and previewing of pages in browsers are also available commands. The 

command to quit Dreamweaver is here, also. 

Edit 

The Edit menu contains commands to undo and redo actions, cut, copy, paste, find, and replace. It also contains 

the preferences command that allows you to customize your own Dreamweaver set-up. 

View 

The View menu shows the display attributes, such as whether gridlines are visible, and whether certain palettes 

or borders are showing. 

Insert 

The Insert menu contains commands to insert various objects such as those listed on the object palette, such as 

line breaks, images, named anchors, tables, etc. 

Modify 

The Modify menu contains commands for modifying various objects such as tables, frames, etc., as well as 

altering links and page properties. 

Text 

The Text menu contains the text formatting commands such as font size, color, type, alignment, etc. It also 

offers spell check. 

Commands 

The Commands menu contains the commands for cleaning up the HTML, applying source formatting, etc. 

Window 

The Window menu allows you to select the various windows and floating palettes or inspectors you may need 

to view. 

Help 

The Help menu allows you to launch the Macromedia Dreamweaver help pages in your browser. The Help 

system is very comprehensive, if a little difficult to use initially. 

 

Beginning a New Page 

1. From File drop and drag to New.   

2. Make sure that the following palettes are displayed: the Properties Inspector  and the Object Palette. If 

not, go to Window and select Objects and Properties. 
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3. Add an introductory title (line of text) to your page and then use the Properties Inspector  to change the 

way that your text appears. Hit the return or enter key to double space skip to the next line. NOTE: If you 

wish to single space to go to the next line, hold down your shift key and then press Enter. 

4. Type in a brief introductory paragraph about you, your professional interests, etc.  Explore the Properties 

Inspector  to change the text so it appears as you wish (e.g. color, size, font, etc). 

5. Type a list of the courses you are teaching and use the list option in the Properties Inspector  to make it a 

numbered list and then a bulleted list. 

6. Create a table using the Objects Palette or by dropping and dragging from the Inser t menu.  Make your 

table two rows by three columns with a border value of 2 and a width of 85%. 

7. Save your document as index.html. NOTE: When you save your document as index.html the browser 

"knows" to look for this document in your virtual space when you simply type in the address (e.g. 

http://www.mywebaddress.edu/). 

 

Changing the Background and Title of Your  New Page 

In the Document window select Page Properties from the Modify menu. The following dialog box will appear.  

 

Change your page's background color and in the Title field type in a title for your page (e.g My Page). 

Don' t forget to always save your work; it will automatically keep the index.html file name. 

 

Tips and Tr icks in Dreamweaver : 
 
1. To go to the next line (of text, for example) you can use either keystroke below, based on how you wish your 
text to be separated. 
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·  To create a double space between lines of text, press the Enter key 
This is a line of text. 

This is another line of text. 

·  To create a single space between lines of text, hold down the Shift key and then press Enter. 
This is a line of text. 
This is another line of text. 

 
2. The Properties Inspector  shows many of the options you may use to change the properties of the element in 
which you are working in Dreamweaver. You may expand or reduce the properties inspector by clicking on the 
inverted triangle in the bottom right corner of the palette. 

 
 
3. To change the title of the page (what appears in the top of the window on the web), you may type it in the 
title field at the top of the window. 

 
 
The title is important in that it helps your user know where they are in relation to the rest of your course or web 
site. Notice the difference between these pages: 
 

NO TITLE 

 

A DESCRIPTIVE TITLE 

 
 

 
Creating Tables in Dreamweaver  

 
Tables are a helpful way to arrange information so that it appears in the format you wish on your web page. 
Tables provide structure for text and graphics and make it easier to line information up both vertically and 
horizontally. 
 
1. To insert a table you can drop from the Insert menu to Table or you can click on the icon on your Objects 
Palette to insert a table. 
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2. A window will pop up asking you to enter your decisions about number of rows and columns, table width (in 
percentages or pixels), border size, and padding/spacing. 

 
 

·  The number of rows and columns can be a starting point since these can be added or deleted as you 
develop your web page 

·  Table widths that are set in percentages will adjust to the size of the window in which they are being 
viewed; table widths set in pixels (chose this by using the drop down menu next to the width field) are 
absolute and format your table so that it appears the same size in any sized window. 

·  Border adds a visible or invisible frame around your table cells. Using a value of 0 creates an invisible 
border or frame around your information. 

·  Cell padding and spacing add white space within and between table cells. An acceptable default for both 
is 2. 

When you have made your decisions about the table, choose OK. Your table will now appear where your cursor 
was positioned. 
 
To Make Changes to Your Table 
 
Position your cursor in the table cell under which you wish to add rows or beside which you wish to add 
columns. Add a series of rows or columns by dropping and dragging from the Modify menu to Table; from the 
fly out menu, choose Insert Rows or Columns. A window will pop up that gives you the option to choose the 
number of rows or columns you wish to insert and if you wish them above or below the selection (where your 
cursor is flashing). 

 
 

If you wish to make other formatting changes to your table (e.g. change the background color of a table cell, 
width of a columns, etc) you may do so by selecting the table (Modify >>Table >>Select Table or with your 
cursor in a table cell pressing control + A twice or apple + A twice). Your properties inspector will display the 
properties of your table. Remember that you can expand these options by clicking on the inverted triangle in the 
lower right corner. 
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PROPERTIES INSPECTOR FOR A TABLE 

 
 

PROPERTIES INSPECTOR FOR A SINGLE CELL WITHIN A TABLE 

 
 
**Note the Horz and Vert fields at the bottom of the single cell properties inspector; you can select from the 
drop down menu next to these elements to force your text within a cell to appear at the top of the cell, at the 
bottom, or centered within the cell. 
 

Inser ting Graphics on a Web Page 

A note about links, graphics and paths: 

To reduce confusion, place all of your pages and images in the same folder. If you have a larger site and wish to 

soft your files into folders or directories, make sure the directory structure on your local computer (e.g. hard 

drive) mirrors exactly the directory structure on your virtual space on the server. This helps to maintain the 

integrity of the path to your pages or images so that when you publish via FTP, your pages will appear 

correctly.  If you don' t do this you may end up with an incorrect path and your page will not display properly. 

Also, a good rule of thumb to follow is to make sure that before you insert graphics in your page, you have 

saved your html document (web page) in the correct location on your hard drive. 

 

 INCORRECT CORRECT 

   

 

To Inser t a Graphic: 

1. Drop and drag from the Inser t menu to Image or click on the image icon (picture of a tree) on the 

Objects Palette. Remember the concept of paths applies to images also!! 

2. Locate your image and click Select. 

3. Check the path of your image in the SRC field in the Property Inspector . 
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Creating L inks in Dreamweaver   

The following information will help understand how to link to: 1/ URLs (addresses on the WWW), 2/ other 

documents in your web site, 3/ links to send an email, and 4/ targets within your web page. 

 

A. To create a link to a URL on the web: 
1. Select text or an image that will serve as your hyperlink. 

2. Go to the Property Inspector  window and type the URL (web address) in the L ink field. NOTE: 

Make sure you type in the complete address including http:// at the beginning of the URL. 

B. To create links between documents: 

1. Select text or an image in your web page that will serve as your hyperlink. 

2. Go to your Property Inspector  (Window > Properties) and do one of the 

following: 

·  Click the folder icon to the right of the Link field to browse and select a file. The path to the 

linked document appears in the URL field. 

·  In the Link field, type the path and file name of the document. 

 

C. To create links within documents (these are called named anchors): 

Named anchors set position place markers in a document (they are also called bookmarks and targets). 

Named anchors are often used to link to a specific topic on the page or back to the top of a document. 

Creating a link to a named anchor is a two-step process. First, you will create a named anchor; second, you 

will create a link to the named anchor. Note: Named anchors are case sensitive. 

1. To create a named anchor: 

a. In the Document window, place the cursor at the point at which you want the named anchor (next to 

an image or bit of text).  
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b. From the Inser t menu, choose Named Anchor or choose the anchor symbol from the Invisibles 

menu on the Objects Palette. 

c. In the Anchor Name field, type a name for the anchor.  

d. If the anchor icon/marker doesn't appear at the insertion point location, choose View > Invisible 

Elements 

2. To link to a named anchor: 

a. In the Document window, select text or an image to create a link to your named anchor.  

b. In the Link field of the Property Inspector , type a number sign (#) and the name of the anchor. For 

example: To link to an anchor named "top" in the current document, type #top. Remember anchors 

are case sensitive. 

c. If you' re feeling adventurous, you can also try the point and click method. Highlight your link (text 

or image) and point with your mouse to the symbol next to the file folder in the Property Inspector  

window that looks like a compass. Holding your mouse down, drag to the anchor symbol and release 

the mouse. Your named anchor has been set. 

More Graphics Fun 

To Inser t a Rollover : 

1. In the document window, place your cursor at the point at which you wish to insert your rollover. 

2. Insert the rollover by using one of these methods: 

·  From the Objects Palette, click the Insert Rollover icon . 

·  Choose Insert > Interactive Images >Rollover Image. 

3. The Inser t Rollover  Image dialog box appears. 

 

4. In the Image Name field, type a name for the rollover image. 

5. In the Or iginal Image field, click Browse and select the image you wish displayed when your page 

loads.  

6. In the Rollover  Image field, click Browse and select the image you wish displayed when the user' s 

mouse passes over the original image. NOTE: You will need to create these two identically sized images 
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in an image editor such as PhotoShop or Fireworks. 

7. It is recommended that you choose the option Preload Rollover  Image so that the images will preload 

in the browser's cache, this means that they will load faster when the rollover is used. 

8. In the When Clicked Go to URL field, click Browse and select the file, or type the web address (e.g. 

http://www.website.com). 

Note: If you don't set a link for the image, Dreamweaver inserts a null link (#) in the HTML source code 

to which the rollover behavior is attached. If you remove the null link, the rollover image will no longer 

work. So either leave the # in the Link field or enter a page or site to which to link. 

9. Click OK to close the Insert Rollover Image dialog box.  

10. Test your rollover by choosing File > Preview in Browser or press F12. In the browser, move the 

pointer over the original image. The initial image should switch to the rollover image. 

To Create an Image Map from an Inser ted Graphic: 

1. Select the image. Click the expander arrow in the lower right corner of the Property Inspector to see all 

properties if they are not already visible. 

 

2. In the Map Name field, type a unique name for the image map. Note: If you are using multiple image 

maps in the same document, make sure each map has a unique name.  

3. To define the image map areas, do one of the following: 

·  Select the circle tool and drag the pointer over the image to create a circular hotspot.  

·  Select the rectangle tool and drag the pointer over the image to create a rectangular hotspot. 

·  Select the polygon tool and define an irregularly shaped hotspot by clicking once for each corner 

point. Click the arrow tool to close the shape. 

Once the hotspot is created, the hotspot Property Inspector  appears.  

4. In the hotspot Property Inspector 's Link field, click the folder icon to browse to the file (web page, 

PDF file, etc.) you wish opened when the hotspot is clicked or type the file name. 

5. In the Alt field, type the text you want to appear as alternative text in text-only browsers.  

Most browsers display this text as a tip or cue when the user pauses the mouse pointerover the hotspot. 

6. Repeat steps 4 through 7 to define additional hotspots in the image map. 

7. Test your image map by previewing it in your preferred browser. 

Some more impor tant information about paths: 
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Document-relative paths are the most appropriate paths to use for local links in most Web sites. They're 

particularly useful when the current document and the linked-to document are in the same folder and are likely 

to remain together. You can also use a document-relative path to link to a document in another folder by 

specifying the path through the folder hierarchy from the current document to the linked document. 

When you specify a document-relative path, you leave out the http:// segment of the web address. You don't 

need this if the web pages are in the same folder in a virtual space, for instance. 

·  To link to another file in the same folder as the current document, simply provide the file name to which 

you wish to link (e.g. linking from the index.html file to the faculty.htm file you would type simply 

faculty.htm in the L ink field in your Property Inspector window). 

·  To link to a file in a subfolder of the current document's folder, provide the name of the subfolder, then 

a forward slash, and then the file name to link to (e.g images 1/ginger.jpg). 

For example, suppose you have a site with this structure: 

 

·  To link from contents.html to hours.html (both files are, in the same folder), you would type 

hours.html. in the Link field. 

·  To link to tips.html (in the subfolder named resources),you would type resources/tips.html in the Link 

field. 

·  Each forward slash (/) represents moving down one level in the folder hierarchy. 

·  To link from contents.html to catalog.html (in a different subfolder of the parent folder), type the path 

../products/catalog.html. 

·  Each ../ represents moving up one level the folder hierarchy. NOTE: This concept is the same when 

inserting images 

NOTE: An incorrect path is the most common source of broken images and pages not found on web sites. 


